Widgets slowing down your website

More problems caused by design – this time a Widget

TLDR : “Block” widgets may cause a problem, install the plugin “Classic Widgets” to return to original widget design

 

I’ve had a lot of problems with the wordpress “Gutenburg” style editor and blocks, and tonight is no different. Ever since upgrading wordpress, they keep trying to push to “block” editors, which is irritating to say the least. I initially installed a classic post editor because I like the plugin more. Now I’ve come across a new problem entirely

I noticed tonight when navigating my blog posts submitting them to sites for SEO that my site was running teribbly slow when switching pages. I say slow as in slow for me. I’m used to instantaneous speed.

My site was taking about 10 seconds to switch pages, when normally it’s instant or within a couple.

When going into my Theme options (my theme is Neve), that I couldn’t change the number of posts I had.

So, since it’s a Widget, I went to Appearance –> Widgets.

Low and behold, a new widget update. Neve (or WordPress upgraded install) switched my editor to use “Block” widgets.

They look horrible, but were running ridiculously slow again.

 

I had a look around, there’s a plugin called “Classic Widgets” that basically reverts your Widget editor to the Classic look

I installed it, and tested with my website again. Low and behold, the pages switch virtually instantly. I did a couple of tests, disabled the plugin, pages take about 10 seconds to load. Enable the plugin, pages take about 2 sec to load when switching

So, another fix carried out… yet again.

 

I hope this helps someone who encounters the same problem

Leave a Reply

Your email address will not be published. Required fields are marked *